Monthly Archives: August 2012

dskMon[19086]: FS /dev/mapper/emc_vg_lun_5-emc_lv_nas_var_emcsupport mounted on /nbsnas/var/emcsupport filling up

Aaa before sleep one more article

We got such warning on Unisphere

dskMon[19086]: FS /dev/mapper/emc_vg_lun_5-emc_lv_nas_var_emcsupport mounted on /nbsnas/var/emcsupport filling up

On that partition some logs file stored 😀 , need to be deleted if its full

/dev/mapper/emc_vg_lun_5-emc_lv_nas_var_emcsupport

552M  472M   52M  91% /nbsnas/var/emcsupport

[nasadmin@ASLANVNX01 ~]$ cd /nbsnas/var/emcsupport

[nasadmin@ASLANVNX01 emcsupport]$ ls -al

total 466265

drwxrwxr-x 3 nasadmin nasadmin     4096 Aug 22 13:02 .

drwxrwxr-x 8 nasadmin nasadmin     1024 Aug 23 22:00 ..

drwx—— 2 root     root        16384 Apr 22  2011 lost+found

-rw-rw-r– 1 nasadmin nasadmin 45309242 Jul  1 03:05 support_materials_CKM00105000413.120701_0257.zip

-rw-rw-r– 1 nasadmin nasadmin 43483801 Jul  8 03:05 support_materials_CKM00105000413.120708_0257.zip

-rw-rw-r– 1 nasadmin nasadmin 46748284 Jul 11 06:39 support_materials_CKM00105000413.120711_0631.zip

-rw-rw-r– 1 nasadmin nasadmin 43792585 Jul 15 03:05 support_materials_CKM00105000413.120715_0256.zip

-rw-rw-r– 1 nasadmin nasadmin 44872969 Jul 22 03:05 support_materials_CKM00105000413.120722_0257.zip

-rw-rw-r– 1 nasadmin nasadmin 46031689 Jul 23 06:09 support_materials_CKM00105000413.120723_0600.zip

-rw-rw-r– 1 nasadmin nasadmin 46466604 Jul 23 07:23 support_materials_CKM00105000413.120723_0715.zip

-rw-rw-r– 1 nasadmin nasadmin 47372360 Jul 29 03:08 support_materials_CKM00105000413.120729_0257.zip

Connect “Control Station” via ssh , go to under  /nbsnas/var/emcsupport folder and delete the oldest file 😀 like below

rm support_materials_CKM00105000413.120701_0257.zip

attantion , rm command will not ask to you (y/n) , delete , thats all

VM

 

Can not delete host entry on VNX via EMC Unisphere

Today we faced deregistered initiator hosts are still on Host List of VNX, no way to remove such records because “Remove” option was Grey

Again, no way to solve such issue without restart service 🙂 very funny

Do step by step

Close EMC Unisphere windows first
Go https://SPA/setup/
Login with credentials
Click on Restart Management Server button
Click Yes
and Submit

wait and control the page again its accessible or not, then switch SPB, do same thing for SPB

then try to access EMC Unisphere , you will see that all entries which need to be removed before are gone 😀

Perfect
VM

After Redhat/Centos come to Debian, hey where are all my known commands and files ….. Round1

i’m too new to Debian, really its very hard to adapt after Redhat and Centos but have to 🙂

First error after installation on log files, its good to fine out messages file on there

WebApp01 mpt-statusd: detected non-optimal RAID status

Aaa, i couldn’t find out great solution but too much people think that its a bug and seen on vmware, but good that i know how can i stop to get such error

issue come from mph-statusd deamon , its looks like used query LSI SCSI HBAs , related process like below

root      1293     1  0 22:05 ?        00:00:00 /usr/bin/daemon /etc/init.d/mpt-statusd check_mpt
root      1294  1293  0 22:05 ?        00:00:00 /bin/sh /etc/init.d/mpt-statusd check_mpt

Need to be stop such deamon on status, but how 😀 this is fantastic, no any command i know but found it

install the related tools to do it like below

apt-get install rcconf

and then run rcconf and its easy remove the asterisk from mph-statusd, if you want remove then its gone

its exactly execute command update-rc.d, command out like below

update-rc.d: using dependency based boot sequencing
update-rc.d: warning: mpt-statusd start runlevel arguments (none) do not match LSB Default-Start values (2 3 4 5)
update-rc.d: warning: mpt-statusd stop runlevel arguments (0 1 2 3 4 5 6) do not match LSB Default-Stop values (0 1 6)

Second error is locale , i was afraid zoo much but same thing on my article helped me , just add lines below under /etc/environment, logout and logon, perfect, working

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “en_US:en”,
LC_ALL = (unset),
LC_CTYPE = “UTF-8”,
LANG = “en_US.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).

to fix ->

LANG=en_US.utf-8
LC_ALL=en_US.utf-8

Just wonder that vmware tools work with it ? I don’t know, downloaded , untar it under /usr/local/src and execute perl vmware-install.pl , error 😀

Error: Unable to find the binary installation directory (answer BINDIR)
in the installer database file “/etc/vmware-tools/locations”.

Nice article http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1013159

rm /etc/vmware-tools/locations

This is happened because i was started installation for test the perl, after some overwrite questions now real questions like where is the binary files 🙂

But before the installation pls check you have gcc and kernel headers , if you do not have install it

apt-get install gcc

apt-get install linux-headers-$(uname -r)

apt-get install make

Note : Still first DVD is mounted

Then install the vmware tools again, reboot the system and check vmware tools status, for me its working

Round 1 over 😉

VM

Fortigate and SSL VPN Configuration

I know you do not have enough time, go !!

First activate SSL VPN on forti.

Need to create ip pool which forti  will set when people connected, you can see below default forti already have such pre-configured one, if you want you can use it or create new object and set ip address range what you want assign to consumers , i generally add /24 C class

Need to modify routing table, add static route and forti should know what it will be do where it will route SSL-VPN source traffic for reach target

Device should be you interface which start with ssl.
No need to set default gw, leave 0.0.0.0 ,forti will handle it
Distance and priority is not important if you do not have other or more preferential one

Portals, i remember that SSL VPN and SSL VPN portals are pushed by Juniper, they have additional SSL VPN boxes for handle this jobs also extra cost and what good in Forti, no need to pay extra for it, but i don’t know what juniper do now !

Portals are used what customer/user sees when they login also applications are important because its affect how you configure the widgets later on

 

Set the name and application what you need, actually i used it for only use it on rules , after all changes pls don’t forget to click apply on left-top site

Pls set the ip range to portal what you created on second step like below and click OK (Click Edit on IP Pools and choose the IP Mode as a Range), after all changes pls don’t forget to click apply on left-top site

Create Users ….

 

Create Group and assign user and portal to group , to do it click SSL-VPN Access and choose portal from drop down , move the user right site

Last 2 steps …

First need to create auth rule, via this we will make authentication, you decide which ip address which destination,which group , which services and go !

and last thing

Where this customers/users allowed to access, need to write down a rule from network which assigned by forti to customer and target, where they need to access

Lets try , link should be like below if you did not change the port number on first step and give the username and pass and try to access

https://forti.out.site.ip:10443/remote/login

i wrote down forti.out.site.ip this is what outside ip of forti or related VDOM outside ip

For extra and more information maybe you would like to check out

http://docs.fortinet.com/fgt/handbook/40mr3/fortigate-sslvpn-40-mr3.pdf

VM